Softwave does not detect Wave ring

OSX El Capitan

Softwave (latest from website) installed

1. Bluetooth is connected (appears in Audio MIDI devices, and Wave appears in connected Bluetooth devices)

2. Turn on Wave ring

3. Start Softwave app

Ring does not appear in device list on Softwave app

As a comparison, I opened Ableton and the Wave is detected. I can map 1 CC to the ring (CC 19) but not other numbers.

Attached is a screenshot of Wave Ring in Ableton, and no Ring in Softwave 

Grateful for help please



  • Same here; the software requested an update, but after that it couldn't see the ring, despite the fact that it appeared in the Bluetooth devices list and worked in MidiBerry. I reinstalled the latest version with the same result, so I had to go back to an earlier version.

  • (Windows 10 19043.)

  • I'm having the same issue, Wave appears in the list when I hit connect wave in softwave. I click on "wave" in the list, goes bold, then blinks bold and non bold a couple times, I hit close, and it isn't listed as connected.

  • Same here!


    ping !


    Please help. Mac M1.



Please sign in to leave a comment.

Didn't find what you were looking for?

New post