Wave for work new version for Mac does not work

Got an update for Wave for Work software for Mac today, but it does not work, it just blinks and dies. 

I saw a thread about Softwave and similar problems with permissions or whatnot. Anything to try before rolling back?



  • I updated yesterday and have the same problem (Catalina OS).

    Would also like to know what to do or where to get the old version app. Thanks in advance.

  • It works now, thanks for updating!

  • Heh, for me it now dies after clicking on Connect. I guess its an improvement, although not by much ;)

  • I met the same problem when I connected it with the "Bluetooth MIDI" app first and then tried to connect it with the Wave app. It crashed every time when I clicked the button. But after I disconnected in "Bluetooth MIDI" and tried again, it just worked. Hope it helps!

  • I'm not using MIDI, but I've just turned Bluetooth off and back on and it started to work. Thanks for the tip!

    Unfortunately, it still does not support Google Meet, so bummer. But it was worth a try ;)

  • Is this software supported for MacOS Ventura?

    I have a Wave Ring that I use for midi CC input.

    Can I not also use the Wave for Work software?


Please sign in to leave a comment.

Didn't find what you were looking for?

New post