Softwave freezes on macOS 10.14 (Mojave)


I'm running Softwave 0.11.2 with Ring firmware 1.6.2 on macOS 10.14.6 (late-2016 macbook pro).

I experience Softwave controls (representing ring movement) freezing when I connect the ring anytime after the first connection (after turning on Bluetooth) and I switch to standalone mode editor. I also stop receiving MIDI in other applications at that time. To be clear: after I restart (turn off/on) Bluetooth in System Preferences and then start Softwave, it works fine for the first time. But once I close Softwave (thus disconnecting the ring) and then re-open it (re-connecting the ring), then switch to standalone mode, the controls stop moving after a few seconds.

I've also tried this with a newer mac running Big Sur and could not reproduce the issue, so this seems to be specific to either macOS Mojave or my laptop.

(I have tried reinstalling Softwave and removing its preferences from Application Support which didn't make any difference, as this issue still occurs). Any ideas how I can make the ring work reliably in standalone editor after re-connecting, without the need to toggle bluetooth on/off?

(As a side note, I can connect Bluetooth MIDI in Audio MIDI Setup, after which I do get MIDI in other applications; however, starting Softwave stops the MIDI from being transmitted



  • Similar issue here with same version of Softwave and firmware, but with Mac OS 10.15.7:  Once entering standalone, MIDI is totally sketchy, coming in bursts, and missing lots of motion.  Display on the ring itself is showing everything smooth.

    In the app - nothing seems to work once you go to standalone editing. 

  • Having the same issue here on OS 10.14.6 every time I enter standalone mode softwave just jumps back to presets and ring B doesn't seem to connect at all. The softwave isn't picking up the ring movements yet third party software is on one ring only (Max MSP)... Any suggestions would be really helpful.

  • I have the same problem with one ring on mac 10.15.7.

    Easiest solution that I've found is to simply disconnect the ring in the system bluetooth config and it instantly come back.  

    Still annoying in a performance !




Please sign in to leave a comment.

Didn't find what you were looking for?

New post