Firmware Update Issues. Can the Wave be reset?

I just received my Genki Wave. I'm on windows 10 and followed all the steps.

The drivers are installed, it's in slot 8 (0-9 as directed), it connects via bluetooth, but now it won't work. 

I clicked the button to upgrade my firmware and it got stuck in a loop. The wave started blinking, it connected, then wouldn't move from 0% and would fail. 

I then tried the iOS update using nRF Toolbox and it won't work either. It connects briefly, but then the status shows as disconnected.

The only message it sends to software is tap. Every other control doesn't do anything.

So my new Genki wave on Win10 won't do anything.


Is there a way to fully reset the wave perhaps and start over with a fresh wave ring so I can update only via nRF? Anyone else have firmware or connection issues on Win10?

It seems the install is much smoother on Mac. Hoping someone can help guide me to get this working :)



  • 1
  • Hello,

    Trying to update firmware on a new Wave on OS X (10.15.7 (19H15)) and having similar issues.

    Any recommendations?

  • Hi, sorry for responding so late!

    If this is still an issue, we've just released a new version of Softwave with new firmware. You can read all about it here.

    If the issue persists, please contact us through support and we'll try to resolve it!

  • I just tried with the new software. The update failed. I tried closing the windows and trying again and it failed again. 


    Is it possible to point directly to it and download the actual firmware file? Perhaps some firewall issue on my work computer is blocking the connection? I can try later on a home pc.

    Also, for loopmidi how does it work in tandem? I imagine I make a new midi input and output port and assign it in the audio/midi settings?

  • Hi Aaron, sorry for the late reply.

    The firmware update is bundled into Softwave so I'm not sure your firewall is blocking it. If updating through Softwave doesn't work, and the manual method through iOS / Android doesn't work either, please file a support ticket and we'll try to resolve it.

    For loopMIDI, there should be no need to create ports manually. Softwave will take care of that automatically.

  • I'm having the exact same issue on a Macbook Pro 2018 (OS 10.13.6).

    I've repeatedly tried to update firmware. The progress bar stays at 0% and eventually I get this error message. The ring will not function without the update.

  • Jackie Gallant,

    Can you try updating the firmware using the manual method described under "I can't update the firmware of my Wave through Softwave" on the troubleshooting page?

  • There is a firmware update, so I ran it, but it stopped.


    So I read the firmware related article and tried it as it is, but it doesn't work.

    What should I do?

  • Hi, Reset!

    You should be able to install new firmware on the ring manually through an Android/iOS device. Please follow the steps listed under "I can't update the firmware of my Wave through Softwave" on the troubleshooting page


    Please note that the device's name will be "Firmware update" instead of "Wave" in step 6.


    For firmware update issues in Wave for Work, you can check also this link:


    Hope this information helps. Please let us know if this is enough to solve the problem.🙂️


  • Hi Genki,


    Everyone followed the instructions but the app does not function as you described.

    1. It doesn't show the WAVE as a Bluetooth device available for connection

    2. On the iOS app there is not a select file feature

    Device : iPhone 12 Pro

    iOS 14.8.1

    rnf Toolbox v 5.0.6



    1. Download rnfTooldbox to iPhone
    2. Launch rnfToolbox
    3. Select DFU (Device Firmware Update)
    4. Observe only options : a. Connect Bluetooth Device (Does not show Wave as a device. Does not show "Firmware Update" as a decice. Lots of N/A devices) b. Update HomeKit Accessory




  • UPDATE :

    1. nrfToolbox was able to see wave as "Firmware Update" after turning off then holding down center wave button hence putting the wave into the pairing mode with flashing lights.
    2. Upon attempting to update the app fails to connect

    # of repros 5/5

    REVISED REPRO STEPS (to get to where I got stuck) :

    Device : iPhone 12 Pro

    iOS 14.8.1

    rnf Toolbox v 5.0.6



    1. Download rnfTooldbox to iPhone on Chrome
    2. Click "OPEN" on the bottom notification bar
    3. Select "nrfToolbox" as the application to open the firmware zip file with
    4. nrfToolbox will show you the DFU screen without letting you know if the unzip happened.
    5. Select DFU (Device Firmware Update)
    6. Select Wave ring as "Frimware Update"
    7. If you dont see Firmware Update as a device turn the ring off then hold down center button until the light flashes super quickly.

      *** Well now I'm unzipping it in Files. UGh and now the ring wont go into pairing mode. This is a nightmare.

    *********** I tried EVERYTHING possible. Zipped unzipped. Nothing works.

  • Hi Hel1x, 

    Thank you for your post. 

    When connecting Wave, please make sure that it's on and not connected (two fading dots on the LED display).

    Please let us know if this works. Thank you!


  • I was able to find the firmware update I needed on the page. Thanks Genki support! I was able to solve this issue.

  • Hi there.  Is there no solution for what HEL1X and aaronbrownsound (hi Aaron!) have asked above?  I have two Wave rings and they both are completely unresponsive with any combination of button presses (long or short) and are both unable to be updated via firmware using the rNF Toolbox. I get the same "Error. Can not create Firmware"  error as shown above despite both devices appearing as "Firmware update" in the bluetooth list.  Both devices are permanently just blinking 1 white light without any response to reset and I guess I"m just going to wait until their battery goes out or return them. Very disappointing first experience for tech.  Definitely not what I was hoping for.

  • For anyone still experiencing this very frustrating problem when trying to do a manual firmware update (especially if you're getting the "Error. Can not create Firmware" error):

    Genki's "manual update" instructions they might have sent you are currently wrong, because they link to a broken firmware update app.  Fortunately, there's an alternative that DOES work.

    In the app they link to on the app stores ("nRF Toolbox"), the "DFU" functionality of that app is broken, and Nordic (the makers of that app and the chipset Genki uses) are aware of it.  They are pointing people to the very specific app called "nRF Device Firmware Update" which can also be found on both Android and iOS app stores.

    So search your app store for "nRF Device Firmware Update".  That app actually *looks* more like what Genki's instructions describe, and it *did* work for me to update my Wave Rings.  Incidentally, I found this all out because the newest firmware (1.7.5) and the newest Softwave (0.13.0) tanked my setup - my rings kept crashing, and even when they didn't, their latency was through the roof.

    I wish Genki was actually active on this support site, but they seem to have disappeared here.  Fortunately, they DID send me old versions of Softwave (0.12.3) and the firmware (1.7.2) so if anyone else is having the issues I'm having, let me know and I can share.

  • Hi Ravi, thank you for your help in this community. I am reaching out where I can now, because I have to get my instrument working again - I was stupid enough to do the update and nothing worked, like you experienced, though support (in November)  I got links to the 12.3 and also to the 1.7.2, and I use the "nRF Device Firmware Update" on my Ipad, but it will not read the files, the message I get  in the app is "No manifest.json file found". Would be grateful for any help here...

  • Hi again, update- it turned out I had a corrupted file. Dowloaded again from Github and it worked!

  • I'm having the same issue as others.  tried (windows 11) to upgrade to latest firmware and now my wave is blinking white light and nothing stops it and it is not updating.  Tried disconnecting windows bluetooth and still just a fast single blinking light. Tried powering down, nope...still blinking. 

    How do I get back to normal mode to try the manual path above? 


  • Thank you, Ravi Gadad for the tip on the right DFU to use! It saved my Wave today!


Please sign in to leave a comment.

Didn't find what you were looking for?

New post