Massive fail with 0.13.0 on Mac. Bricked my Wave. But, here is how I recovered.

So, 0.13.0 said there was a firmware update 1.7.7. I tried to dismiss it, but it just kept popping up. Could not do anything else.

So, I updated. After update, it will NOT connect to either the Softwave software, or to the BLE MIDI on the Mac. They both say "connected", but the Wave Ring just sits there with the 2 LED dots soft blinking as if not connected.  And no MIDI data is received on the Mac.

Fortunately, 1.7.2 was still available to download. BUT, the update software linked from the support page DOES NOT WORK (at least, on iOS; idk about Android). Thanks to a post by Ravi Gadad on another thread, I found out that you need to download a DIFFERENT software called "NRF device firmware update". This one does work, and I was able to downgrade. Also, I had saved the older Softwave as well, and that works fine, without the insistent popup about upgrading firmware. I am back to working now, but after many hours of anxiety.

I am sticking with the old versions of Softwave and the firmware until people post here that the new ones actually work.



  • Can you point us that link or both?


  • I haven't been able to use my Wave since this update. I have tried repeatedly to get support help - they just ask me a few questions then ghost. It's so frustrating as this thing was fantastic when it was working but now it's just an expensive useless bit of jewellery. I'll have a look at what you've suggested but if anyone else is having this problem or has a solution it would be great to hear about it. I'm so, so disappointed in this company. 

  • I was having problems both before and after the updates (both firmware and softwave).  After, what seemed like Bluetooth dropouts were intolerable.  If that's what's happening to you, well I did fix. 

    macOS Ventura
    M1 MacBook Air

    If you're not using Mac, maybe stop reading here.

    Turned WiFi off completely.  Removed ("forgot") all Bluetooth devices from Bluetooth Settings.  Restarted computer.  The dropouts are gone. 

    I hear you now: "WHAT??  Live without all other Bluetooth, no networking??!?!"

    Well of course. As a self-respecting musician using software, plug-ins, interfaces, controllers, I can't be subject to the whims of OS updates and the demands of other software. They can't make me touch my music system. 

    I work on music in a separate startup partition or a completely different Mac. 

    Don't you?

  • Joshua, my issue was quite different. Not dropouts, but just plain failure to connect.

    Keyboardkat, I looked for the link, but looks like they have now updated the firmware to the latest, which did not work for me. I am quite loathe to try it again, after the last disaster. I am so sorry that support is ghosting you. They tend to do that. However, they do seem to ping the developers who fix the problems when they get to it.

    I wish they would keep older versions available to download for people that have issues with the latest. But they don't. If you want, I can try to send direct to you. Email me at krish kal (remove space there) which is on gmail. Don't want to post the email address directly as it will likely get farmed for spam.

  • hello Kal Krishnan, i have the same problem and i am not able to find an older firmware, could you share it to me please?


  • Barrypwan, I don't think I can attach a file on this forum. Please look at my previous post and send me a PM, and I can share that way.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post