WaveRing firmware update Problem

There was  softwave update and  firmware update. After updating the firmware the wave ring does not work properly. It lost connection all of a sudden from  softwave and also from MIDIberry. Also  newly created or edited preset in standalone mode  get lost after disconnecting from softwave.  And  "+" button in standalone mode does not work to add preset.  Is there any way to go back to previous firmware or how to fix this problem. 

0

Comments

5 comments
  • Official comment

    Hello, Minhaj!

    Sorry for the trouble and inconvenience. 

    Until we figure out the root of the problems with 0.13.0 and firmware 1.7.5, below are 

    the previous versions:
    You will first have to install the previous firmware version for Wave manually through an Android/iOS device. The firmware update and instructions can be found here (important: Use the 1.7.5 firmware, not the firmware linked in the instructions).

     

    Hope this helps!

  • Ah, good, thank you Genki for finally starting to respond here!

    Minhaj, FYI, so you don't run into the same frustrating issue I did, those "firmware update instructions" linked in that message are incorrect - they tell you to download a broken app ("nRF Toolbox", which Nordic themselves say has a broken DFU (device firmware upgrade) function).

    Search the app store for an app called "nRF Device Firmware Update" (also made by the same company), and use that instead - it will work to downgrade your Wave ring.

    Also note that in their message above, the Genki rep accidentally says "use the 1.7.5 firmware" and the link they have in there says "1.7.5" - but don't worry, the actual linked firmware is 1.7.2 (the old working firmware).

    0
  • I encountered the same problems in the standalone mode, but managed to downgrade the firmware using "nRF Device Firmware Update." Thank you, Ravi. I hope that the next update of the firmware and Softwave will fix the problems in the standalone mode.

    0
  • Hi, I am struggling with the same issues- but the "nRF Device Firmware Update" will not read the files for 1.7.2 . If anyone has a working version of the downgrade files og any tips I would be very grateful.  No response from support so far.

    0
  • Update- here as well:- it turned out I had a corrupted file. Dowloaded again from Github and it worked! https://github.com/genkiinstruments/releases/releases/tag/softwave

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post